$re = '/^(\d{2})(-)\1\2\1\2\1$/m';
$str = '33-44-55-66
33-33-33-33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);