$re = '/\b[A-Z]+\b/';
$str = 'This is a STRING of WORDS to search';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);