package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:\s*\[(\s+\S[^\]\[]+)\]`)
var str = `{
"key: [
]
"match": [
1
2,
3,
4
]
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}