$re = '/[^(?<!\s*acteMedical)]\w*Dao\./m';
$str = 'acteMedicalDao.selectListeMotifsByActe(idPaam);
acteMedicalDao.selectListeMotifsByActe(idPaam);
basParamBilanDao.delete(id);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);