$re = '/\b(?:l\w*ion|test|one|two|three)\b/';
$str = 'This is my liar dfsglotion
This is my lotion';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);