package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(go)+`)
var str = `Gogogo now!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}