$re = '/^(?:.{0,10}|.{12,}|[a-zA-Z]{6}[a-zA-Z0-9]{5})$/m';
$str = 'abc def
abcde12345
aaaaaaaaaaaaaaaaa
aaa4aaa*aa5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);