$re = '/\bCL_.*?(?=\s*CL_|$)/';
$str = 'CL_6x CL_5c CL_234 CL_ERB14 1D CL_6y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);