import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+([-+.]\\w+)*@\\w+([-.]\\w+)*\\.\\w+([-.]\\w+)*";
final String string = "Please contact us at: support@github.com.\n\n"
+ "Just send email to s.miller@mit.edu and j.hopking@york.ac.uk for more information.\n\n"
+ "Many users @ SoftUni confuse email addresses. We @ Softuni.BG provide \n"
+ "high-quality training @ home or @ class. –- steve.parker@soft.de.\n\n"
+ "• Examples of valid emails: info@company-hotels.org, kiki@hotmail.co.uk, no-reply@github.com, s.peterson@mail.uu.net, info-bg@software-software.software.academy. \n\n"
+ "• Examples of invalid emails: --123@gmail.com, …@mail.bg, .info@info.info, _steve@yahoo.cn, mike@helloworld, mike@.unknown.soft., s.johnson@invalid-.\n\n\n"
+ "\\b(\\b[\\w.\\w]+\\b)@(\\b[\\w.\\w]+\\b)\\b\n\n"
+ "\\w+([-+.]\\w+)*@\\w+([-.]\\w+)*\\.\\w+([-.]\\w+)*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}