import Foundation
let pattern = #"SID_W_MAX_TRAN_DT.+?=(?=\s) (?<SID_W_MAX_TRAN_DT>[^\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MID_COUNT =========== 20,588,655
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
Table.+.+?(?=\.)\W*(schema.table_name)\W.+?(?=,+)\,\s+numRows\=+(?<LogTime>[^\,]+)
Loading data to table schema.table_name
Table gmr.opcode_tedc_cs_gmr_id_delta stats: [numFiles=5, numRows=8986691, totalSize=937732401, rawDataSize=928745710]
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 997 100 997 0 0 114k 0 --:--:-- --:--:-- --:--:-- 162k
0 0 0 397 0 0 1650 0 --:--:-- --:--:-- --:--:-- 1650
SID_W_MAX_TRAN_DT ========== 9,070,691
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 997 100 997 0 0 108k 0 --:--:-- --:--:-- --:--:-- 139k
0 0 0 403 0 0 944 0 --:--:-- --:--:-- --:--:-- 944
NON_PSP_SID_COUNT =========== 39,869,169
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 997 100 997 0 0 112k 0 --:--:-- --:--:-- --:--:-- 162k
0 0 0 398 0 0 7223 0 --:--:-- --:--:-- --:--:-- 7223
PSP_SID_COUNT =========== 45,083
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)