re = /(\d{4}-\d{2}-\d{2})-(\d{2}:\d{2}:\d{2})/
str = '        hour         
---------------------
 2014-12-06-01:44:35
 2014-12-06-01:44:35
 2014-12-06-01:44:35
 2014-12-06-01:44:35
 2014-12-06-01:44:35
 2014-12-06-01:44:35'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result