$re = '/(Test[\d])_([\w]+)_([\w]+)/';
$str = 'Test1_MYSTRING_val1
Test1_MYSTRING';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);