re = /(?!^(\d{1,3}\.){3}\d{1,3}$)(^[a-z0-9]([a-z0-9-]*(\.[a-z0-9])?)*$)/
str = 'a.b.c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end