package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\",]+|\"[^\"]*\"`)
var str = `Data1,Data2,"Data 3, more", Data 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}