using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\w)(\w+(?=$|\s))? *\b(\d+\.\d+)?";
string input = @"G1 13.00
G1 3.00
0.00
27C
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}