using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)([0-9]{8}.+)(?=<)";
string input = @"<option value=""20150110.1932.mtsat_2.visir.bckgr.NW_Pacific_Overview.DAYNGT.jpg"">20150110.1932.mtsat_2.visir.bckgr.NW_Pacific_Overview.DAYNGT.jpg</option>
<option value=""20150110.1901.mtsat_2.visir.bckgr.NW_Pacific_Overview.NGT.jpg"">20150110.1901.mtsat_2.visir.bckgr.NW_Pacific_Overview.NGT.jpg</option>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}