$re = '/^(.*)(?=IF EXIST %logfile% DEL %logfile%)/';
$str = '@echo off
:: ** Script generated by Reporting Services Scripter 2.0.0.17 **
:: ** Created by Jasper Smith (jas@sqldbatips.com) **
:: ** See http://www.sqldbatips.com for help/support **
::Script Variables
SET LOGFILE="RS Scripter Load Log.txt"
SET SCRIPTLOCATION=
SET BACKUPLOCATION=
SET REPORTSERVER=https://frparodyssee.corp.xxx.com/ReportServer_ODYSSEE_DEV
SET RS="C:\\Program Files\\Microsoft SQL Server\\100\\Tools\\Binn\\RS.EXE"
SET TIMEOUT=60
::Clear Log file
IF EXIST %logfile% DEL %logfile% some other text
The rest of the text !!!';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;