$re = '/(^[0-9]{8,8}$)|([0-9]{2,2}[\-]?[A-Z]{1,1}[0-9]{7,7}([\-\/]?[0-9][0-9]?))/';
$str = '
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);