package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\w{3,8}\b`)
var str = `words with length three to eight`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}