$re = '`^.*/([^/]{1,6})[^/]*$`m';
$str = 'people/capital/base/flagedbylogger5
people/capital/base/no';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);