package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`foo\("this is a string"\)`)
var str = `foo("this is a string")`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}