using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([А-Я]{1}[^.]+[.]{1})";
string input = @"Инструменты и техники программирования очень выживают и распространяются хаотично-эволюционным способом. Иногда выживают не красивые и гениальные, а просто такие, которые достаточно хорошо работают в своей области – к примеру, если их интегрируют в другую успешную технологию.В этой главе мы обсудим такой инструмент – регулярные выражения. Это способ очень описывать шаблоны в строковых данных. Они создают небольшой отдельный язык, который входит в JavaScript и во множество других языков и инструментов. Регулярки одновременно очень странные и крайне полезные. Их синтаксис загадочен, а программный интерфейс в JavaScript для них неуклюж. Но это мощный инструмент для исследования и обработки строк. Разобравшись с ними, вы станете очень эффективным программистом.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}