$re = '/(?i)und\D+(\d+)/';
$str = 'Kunde.-Nr.: 122222';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);