$re = '/[a-zA-Z0-9]+(?=,)/';
$str = 'rb40425,Fri Jan 30 11:35:33 2015@ot7293,Fri Jan...."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);