import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[.?!;]|[.!?][\\'\"”])(?<!Mr\\.|Mrs\\.|Ms\\.|Jr\\.|Dr\\.|Ir\\.|Prof\\.|\\.\\.|\\.\\.\\.|Sr\\.|T\\.V\\.A\\.)\\s+(?=\\p{Lu}|[“\"])";
final String string = "Maher Zain is a global sensation. With 22 million Facebook fans — that’s more than Madonna — he is by far the biggest name in Islamic music today. “I’m so scared,” he says. “What if one morning I just wake up,” he clicks his fingers, “and boom, my intentions change. What if I’m no longer the same person? It scares me a lot.” Zain is sitting in the back of a bus that is taking him to perform in Glasgow. Touring Britain with the charity Human Appeal, visiting 11 cities, along with three other artists from his record label, Awakening Records, he is concerned that one day his fame could overwhelm him. Right now, however, there are no signs to suggest that. In fact, the opposite is true: despite two multi-platinum albums, hundreds of millions of views on Youtube, and even knocking Justin Bieber off top spot with his debut album in Indonesia, he is as grounded as ever. In 2007, Zain, a Lebanese-born Swedish musician, was in the United States, preparing for the next stage of his career.";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}