package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(, [A-Z])`)
var str = `Non MMF investment funds, Insurance corporations, Assets (Net Acquisition of), Loans, Long-term original maturity (over 1 year or no stated maturity)
Non financial corporations, Financial corporations other than MFIs, insurance corporations, pension funds and non-MMF investment funds, Assets (Net Acquisition of), Loans, Short-term original maturity (up to 1 year)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}