re = /^(https?:\/\/)?(www\.)?/m
str = 'http://www.website.com
https://www.website.com
http://website.com
https://website.com
www.website.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end