const regex = /\@((TIME|NOW|TODAY)\([^@]*?\)\s+[0-2]?[0-9]:[0-5][0-9]:[0-5][0-9])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\@((TIME|NOW|TODAY)\\([^@]*?\\)\\s+[0-2]?[0-9]:[0-5][0-9]:[0-5][0-9])', '')
const str = `@Time blah blah @TIME(1d) blah @NOW(12312) 12:32:25 blah @TODAY(12312) 12:32:25`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}