import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%[a-z0-9]+(?=\\s|$)|(?:^|(?<=\\s))%[a-z0-9]+";
final String string = "1. %xxxxxxxxxxxxx //match\n"
+ "2. this will work %xxxxxx but not this%xxxxxxxxx. //match 1st, not 2nd\n"
+ "3. and also %xxxxxxxxxx. //match\n"
+ "4. just a line ending with %xxxxxxxxxxx //match\n"
+ "5. %Xxxxxxxxxxx //no match\n"
+ "6. 100% of dogs //no match\n"
+ "7. 65%. Begining of new phrase //no match\n"
+ "8. 65%.Begining of new phrase //no match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}