package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)s"[^$]*?"`)
var str = `Eppendorf (2).xls`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}