$re = '/(\w+)\s+name\s*=\s*"([^"]*)/';
$str = 'feature name fasfjah fjkhas kfhajk hkask name="test" feature name="test"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);