package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\"([^((,\")|(\",))]*)\"|,\"([^((,\")|(\",))]*)\"
`)
var str = `"0213379","P","2014",,"","2015","2015","95BAD1D8","Macan S Diesel 18" Räder","951","4T4T","VO","$BI 0M2 0NA 0TD 1BK 1G1 1N3 2JX 2ZH 4A3 6H1 7X2 8JE 9JB C11 PE5 PP8 QE1 QJ6 VR4","B","","1510","","","","","","2014-06-04 00:00:00","","2014-06-04 00:00:00","2014-06-06 00:00:00","","V","K","N","N","N","2014-06-04 00:00:00","","","400","400","J","PIA GRAZ-L","400","PIA GRAZ-L","","","56193.72","63139.01","96","2014-06-04 00:00:00","M","","Walter Josef","Müller","A","8530","Deutschlandsberg","","","","","","","","Feilhofengasse 8","","","","","","","","","","","","","","","","","","","","","Herr","","Rabel","Rene","","","","","","","","","","","2015","03","OR","OR","","258","190","2967","D","4","PDK","A","14","6.7","5.7","6.1","161",".0002","J",".0582","","","",""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}