re = /(?:\s*(?:\"([^\"]*)\"|([^,]+))\s*,?|(?<=,)(),?)+?/
str = ' " ab cd " , " efgh,ijk.",, 4,"lmno", e " sdf " sdfpas,,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end