const regex = /[-A-Za-z0-9+&@#\/%?=~_|!:,.;]+[-A-Za-z0-9+&@#\/%=~_|]manifest\.f4m(?=("|\s))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[-A-Za-z0-9+&@#\\\/%?=~_|!:,.;]+[-A-Za-z0-9+&@#\\\/%=~_|]manifest\\.f4m(?=("|\\s))', '')
const str = `{"feedtype": "playlist", "base_url": "http://feeds.xhis.com/rteavgen/player/", "feed_title": "Single Item Playlist", "feedid": "playlist", "alt_url": "http://www.xhis.com/player/#v=10322367", "platform": "iptv", "current_date": "2014-11-14T12:24:39.84167", "full_url": "http://feeds.xhis.com/rteavgen/player/playlist?type=iptv&showId=10343367", "shows": [{"itemid": 10332367, "showid": 11544367, "valid_start": "2014-11-13T21:37:39", "ispodcast": 0, "programmeid": 1, "BRINumber": "ih011305791", "duration": 2053247, "id": 10323367, "media:group": [{"rte:server": "http://vod.hds.xhis.com/hds-vod", "medium": "video", "url": "/2014/1113/20141113-dumbydoozle_cl10344367_10344406_260_/manifest.f4m", "type": "video/mp4", "i`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}