package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]{1,4}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5])(?::([0-9]{1,4}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))?$`)
var str = `Allowed:
6112
6112:6120
27015:28000
Not allowed:
6112:
:6113
6112-7777
27100;28000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}