$re = '`\|\s([^\s|][^|]*SP)\s\|`m';
$str = 'abcd abcd | abcde | Degree SP | xyz abcd | abcd ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);