package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\w\s]|_`)
var str = `adadd_@#@$$fd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}