re = /^[a-zA-Z0-9 @#$^,:\(\)_+\[\]{}~]+$/
str = 'Not allowed List : \' " < > & ! = - / \\ % *
±!@#$%^&*()_+=-§ < >[]{}:;\'"|~`?,.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end