#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\(?\b(?P<book_name>Gen(?:esis)?|Exo(?:dus)?|Lev(?:iticus)?|Num(?:bers)?|Deut(?:eronomy)?|Josh(?:ua)?|Judg(?:es)?|Ru(?:th)?|(?:1st|1|First)\ Sam(?:uel)?|(?:2nd|2|Second)\ Sam(?:uel)?|(?:1st|1|First)\ Kings|(?:2nd|2|Second)\ Kings|(?:1st|1|First)\ Chr(?:onicles|on)?|(?:2nd|2|Second)\ Chr(?:onicles|on)?|Ezr(?:a)?|Neh(?:emiah)?|Est(?:her)?|Job|Psa(?:lms?)?|Prov(?:erbs)?|Eccles(?:iastes)?|Songs|(?:Song\ of\ )?Solomon|Isa(?:iah)?|Jer(?:emiah)?|Lam(?:entations)?|Eze(?:kiel)?|Dan(?:iel)?|Hos(?:ea)?|Joel|Am(?:os)?|Obad(?:iah)?|Jon(?:ah)?|Micah|Na(?:hum)?|Hab(?:akkuk)?|Zeph(?:aniah)?|Hagg(?:ai)?|Zech(?:ariah)?|Mal(?:achi)?|Matt(?:hew)?|Mark|Luke|John|Acts|Rom(?:ans)?|(?:1st|1|First)\ Cor(?:inthians)?|(?:2nd|2|Second)\ Cor(?:inthians)?|Gal(?:atians)?|Eph(?:esians)?|Phil(?:ippians)?|Col(?:ossians)?|(?:1st|1|First)\ Thess(?:alonians)?|(?:2nd|2|Second)\ Thess(?:alonians)?|(?:1st|1|First)\ Tim(?:othy)?|(?:2nd|2|Second)\ Timothy|Tit(?:us)?|Philem(?:on)?|Heb(?:rews)?|James|(?:1st|1|First)\ Peter|(?:2nd|2|Second)\ Peter|(?:1st|1|First)\ John|(?:2nd|2|Second)\ John|(?:3rd|3|Third)\ John|Jud(?:e)?|Rev(?:elation)?)\b\s?(?P<chapter>\b(?:150|1[0-4]\d|[1-9]\d|[1-9])\b(?!\s*-\s*\d+\b:)(?:\s*-\s*\b(?:150|1[0-4]\d|[1-9]\d|[1-9])\b)?(?!\s*:\s*,))(?:\s*:\s*(?!\s*,)(?P<verse>(?:(?:\s*,\s*)?\b(?:17[0-6]|1[0-6]\d|[1-9]\d|[1-9])\b(?:\s*-\s*\b(?:17[0-6]|1[0-6]\d|[1-9]\d|[1-9])\b)?)+))?\)?"
Local $sString = "SHOULD MATCH:" & @CRLF & _
"# Single chapters only:" & @CRLF & _
" 2nd Kings 1 2 Kings 1 Second Kings 1" & @CRLF & _
" Genesis 1 (Genesis 1) Gen 1 (Gen 1)" & @CRLF & _
" matthew 4" & @CRLF & _
" 1 chr 1 2nd Chron 3 1st Chronicles 8" & @CRLF & _
"" & @CRLF & _
"# Single chapter with single verse:" & @CRLF & _
" Gen 1:1 Genesis 1:1 (Gen 1:1)" & @CRLF & _
"" & @CRLF & _
"# Single chapter with range of verses:" & @CRLF & _
" Ezra 1:1-3 Hos 150:175-176" & @CRLF & _
"" & @CRLF & _
"# Single chapter with comma-separated verses:" & @CRLF & _
" Daniel 5:6,7 Daniel 1:2,3,4" & @CRLF & _
"" & @CRLF & _
"# Range of chapters:" & @CRLF & _
" Genesis 1-5 Ruth 99-150" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"SHOULD NOT MATCH:" & @CRLF & _
"# Verse only" & @CRLF & _
" Job :3" & @CRLF & _
"" & @CRLF & _
"# Range of chapters WITH verse:" & @CRLF & _
" Psalms 1-3:4" & @CRLF & _
"" & @CRLF & _
"# Range of chapters WITH range of verses:" & @CRLF & _
" Proverbs 33-44:55-66" & @CRLF & _
"" & @CRLF & _
"# Chapter with comma before verse:" & @CRLF & _
" Solomon 5:,4" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")