$re = '/(\w+(?:-\w+){4})/';
$str = 'Is there any way to create a regex matching *-*-*-*-* (a string with 4 ", so it would match 1-2-3-4-5, AB-CD-EF-GH-IJ but not 9-8-7 ?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);