$re = '/-?\d+(\.\d+)?/m';
$str = '123.45
1.233
1.2
1.23
12.34
-111111.11
2323
"-232323.3443"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);