$re = '/^((?=.*\w)|(?=.*\d])).{8,}$/m';
$str = '#$$$$$$t
#$$$$$$&
sdfsdfds
34sfsdfd
%$$$%??r';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);