package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:\d{5}-\d{4}|\d{5})\b`)
var str = `Zip:
----
98839-0111
34332`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}