$re = '/^[0-9]+(\.[0-9]+)?$/m';
$str = '123.45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);