using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^'|[^\\](')[']+|([^\\])'";
string substitution = @"$1""";
string input = @"""Hello there! I\''''''m \'Doug\'""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}