$re = '/(?<=-{1,2})(?:to?)=?\s*([^\s]*)\s*/m';
$str = '-to= 2000_01_01 -from 202342';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);