#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z][0-9][A-Za-z] ?[0-9][A-Za-z][0-9]$"
Local $sString = "EMERGENCY MEDICINE UNIVERSITY OF ALBERTA HOSPITAL " & @CRLF & _
"" & @CRLF & _
"EMERGENCY MEDICINE UNIVERSITY OF ALBERTA HOSPITAL 1A7 WMC" & @CRLF & _
"" & @CRLF & _
"H2L 2N9" & @CRLF & _
"" & @CRLF & _
"H2L2N9" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")