package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\\|1\\|)+`)
var str = `test_string`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}