$re = '/(?<=\$)\S+(?=\s*Regular)/i';
$str = 'Shipment price $11 Regular shipment
Shipment price $15 Express shipment ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);