re = /^([\w-]+(?:\.[\w-]+)*)@((?:[\w-]+\.)*\w[\w-]{0,66})\.([a-z]{2,6}(?:\.[a-z]{2})?)$/
str = 'foo@dev.baz.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end